use strict;
my $str = 'def g(n:Int) = {
var vec = Vector.fill(0)(Vector.fill(0)(1))
for (p <- 1 to n) {
var vec2 = Vector.fill(0)(1)
for (q <- (p-1)*n+1 to p*n) {
vec2 = vec2 ++ Vector(q)
}
if (p%2==1) vec = vec ++ Vector(vec2)
else vec = vec ++ Vector(vec2.reverse)
}
println(vec)
}';
my $regex = qr/[\w\s]+[\w\(\):]+[\w\(\)<\-\s{=;+*%\.}]+/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}