# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<Title>).{6}/$1/g;t' <<< "<Title>0001: Title1</Title>
<Title>0002: Title2</Title>
<Title>0003: Title3</Title>"