Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
r"
(0\.5)|(\.5)|([0-9]*?)\.5((?(1)| ))
"
Input 1
1
New
skdsd .5 cups
Substitution
\{3}\{4}1/2\{4}
skdsd .5 cups