#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "[\u2070-\u209f\u00b0-\u00be]+"
Local $sString = "2⁰¹²³⁴sometext⁵⁶⁷⁸⁹"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)