package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[\u2070-\u209f\u00b0-\u00be]+`)
var str = `2⁰¹²³⁴sometext⁵⁶⁷⁸⁹`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}