use strict;
my $str = '2⁰¹²³⁴sometext⁵⁶⁷⁸⁹';
my $regex = qr/[\u2070-\u209f\u00b0-\u00be]+/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";