// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[\u2070-\u209f\u00b0-\u00be]+").unwrap();
let string = "2⁰¹²³⁴sometext⁵⁶⁷⁸⁹";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}