$re = '/(?:\G(?!^)|^(?!a))\D*\K\d+/m';
$str = 'abax 45456xx888z 89776uuu
bax 55456xx888z 99776uuu
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);