using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<div class=""head"">[\s\r\n]*([\w ]+)[\s\r\n]*<\/div>";
string substitution = @"<h1>$1</h1>";
string input = @"<div class=""head"">
Keep this text</div>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}