$re = '/<div class="head">[\s\r\n]*([\w ]+)[\s\r\n]*<\/div>/';
$str = '<div class="head">
Keep this text</div>';
$subst = "<h1>$1</h1>";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;