$re = '`([^,]*,){1}([^,]*)(,.*)?`';
$str = '"A","B","C","D"';
$subst = "$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;