import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\d+\\.?\\s*)?(?<place_type>int|ext|est)\\.?\\s*(?<place>.*?)\\s+-\\s+(?<when>.*?)\\s*$";
final String string = "EXT. PUB - NIGHT\n"
+ "4. INT. Bedroom - night\n"
+ "EXT Garden - morning\n"
+ "ext. Garden - midday \n"
+ "2. INT. Kitchen - evening\n"
+ "1 Ext By the lake - night\n"
+ "10. int. In bed - night";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}