const regex = /(CJ2\d)_V2r/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(CJ2\\d)_V2r', 'gm')
const str = `CJ21_V2r
CJ22_V2r`;
const subst = `$1r_V2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);