package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:\d{2}:\d{2}:\d{2} - (?:\[[^\]]*\] )?)([\w: -]+)`)
var str = `INFO: Device 6: Time 20.11.2015 06:28:00 - [Script] FunFehlerButton: Execute [0031 text]
and
INFO: Device 0: Time 09.12.2015 03:51:44 - [Replication] FunFehlerButton: Execute
and
INFO: Device 6: Time 20.11.2015 06:28:00 - FunFehlerButton: Execute`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}