const regex = /^(\w{2,}\s\s*)*(\w{2,})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\w{2,}\\s\\s*)*(\\w{2,})$', 'gm')
const str = `city, country
ok, city,country,
n, foo, bar
foo, bar, n
,foo, bar, test
foo,bar
foobar`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}