$re = '/^(?=.{10,}$)(?=.*?[A-Z].*?[A-Z])(?=.*?([\x20-\x40\x5b-\x60\x7b-\x7e\x80-\xbf]).*?(?1).*?$).*$/m';
$str = 'alsjkdhDflkalskjdf;klGasdf
akjsdhf
asdfas;;jhbsHHHJHdd
A3425cf2345Wcc2345vcdf
sdJIOJjhhhgiuufk
@::}}@}@}IHKJHKJ88ujjj
ssss
ss11!S';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);