$re = '/(?<![private|public|protected|static]\s)function\s.*?\(.*?\)\s?{/';
$str = 'function (asdsa) {
static function (asdsa){
protected function (asdsa){
private function (asdsa){
public function (asdsa){';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);