#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:^(?<year>-?(?:[1-9][0-9]*)?[0-9]{4})-(?<month>1[0-2]|0[1-9])-(?<date>3[01]|0[1-9]|[12][0-9])T(?<hours>2[0-3]|[01][0-9]):(?<minutes>[0-5][0-9]):(?<seconds>[0-5][0-9])\.(?<ms>[0-9]+)?)(?<offset>Z|[+-][0-5][0-9](?::?[0-5][0-9])?)?$"
Local $sString = "2019-04-10T11:07:58.846" & @CRLF & _
"2019-04-10T11:07:58.846+03:00" & @CRLF & _
"2019-04-10T11:07:58.846-03:00" & @CRLF & _
"2019-04-10T11:07:58.846+0300" & @CRLF & _
"2019-04-10T11:07:58.846-0300" & @CRLF & _
"2019-04-10T11:07:58.846Z" & @CRLF & _
"2019-04-10T11:07:58.846+03" & @CRLF & _
"2019-04-10T11:07:58.846-03"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")