$re = '/SET(.*?)WHERE/ms';
$str = 'UPDATE pass
SET stato = -3, descr_stato = \'Scartata\' WHERE pratica = \'1458\'
AND stato = 0
AND anno IN (2016, 2017, 2018);
UPDATE pass
SET stato = -3, descr_stato = \'Scartata\'
WHERE pratica = \'2383\' AND stato = 0 AND anno IN (2020);';
$subst = "WHERE";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;