# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/SET((.|[\r\n\u2028\u2029])*?)WHERE/WHERE/g;t' <<< "UPDATE pass
SET stato = -3, descr_stato = 'Scartata' WHERE pratica = '1458'
AND stato = 0
AND anno IN (2016, 2017, 2018);
UPDATE pass
SET stato = -3, descr_stato = 'Scartata'
WHERE pratica = '2383' AND stato = 0 AND anno IN (2020);"