package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`SET((.|[\r\n\u2028\u2029])*?)WHERE`)
var str = `UPDATE pass
SET stato = -3, descr_stato = 'Scartata' WHERE pratica = '1458'
AND stato = 0
AND anno IN (2016, 2017, 2018);
UPDATE pass
SET stato = -3, descr_stato = 'Scartata'
WHERE pratica = '2383' AND stato = 0 AND anno IN (2020);`
var substitution = "WHERE"
fmt.Println(re.ReplaceAllString(str, substitution))
}