import Foundation
let pattern = #"(video.*?)%7bmatch%7d"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
video://lots0fr@ndomcharact#Rsinbetweenof1nd1scrimin@length/%7bmatch%7d/lots0fr@ndomcharact#Rsinbetweenof1nd1scrimin@length
audio://lots0fr@ndomcharact#Rsinbetweenof1nd1scrimin@length/%7bmatch%7d/lots0fr@ndomcharact#Rsinbetweenof1nd1scrimin@length
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1REPLACEMENT_HERE"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)