use strict;
my $str = ' /^(?<transDate>\\d{2}\\/\\d{2})\\s+(?<postDate>\\d{2}\\/\\d{2})\\s+(?<merchant>[A-Z\\s\\*\\d]+?)\\s+(?<webInfo>[A-Za-z0-9\\.\\/]+)\\s+(?<ref1>\\d+)\\s+(?<ref2>\\d+)\\s+(?<amount>\\d+\\.\\d{2})$';
my $regex = qr/^(\d{2}\/\d{2})(?:\s+(\d{2}\/\d{2}))?\s+(.+?)\s+(\d{4})(?:\s+(\d{4}))?\s+(\d+\.\d{2})$/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}