re = /<in>|\s+.*?(?=\b\w+<in>)/
str = 'application<in>rid and test<in>efd'
subst = '\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result