re = /(?P<MAC_address>([0-9A-Fa-f]{2}[:-]){5}([0-9A-Fa-f]{2}))/
str = 'Username entry (random@somewhere.org) with length (253) created for mobile aa:aa:aa:aa:aa:aa
Username entry (hello) is deleted for mobile aa:aa:aa:aa:aa:aa
Guest user logged in with user account (randomnonexistentuser) MAC address aa:aa:aa:aa:aa:aa, IP address 127.0.0.1.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end