$re = '/[a-z,A-Z,0-9]/';
$str = '1223s;lkdsfgj;dflsgkjsdапвыопждвполыжвпдолж
?*№?%:№№%%?)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);