package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d{2,4})(-|\/|:)(\d{1,2})(-|\/|:)(\d{1,2}) \d\d:\d\d(:\d\d){0,1}`)
var str = `15-15-01 12:01:23
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}