// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\d{2,4})(-|\/|:)(\d{1,2})(-|\/|:)(\d{1,2}) \d\d:\d\d(:\d\d){0,1}").unwrap();
let string = "15-15-01 12:01:23
";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}