$re = '/(?<!\/\s)(function.*?\})(?=\R+(?:function)?|\Z)/s';
$str = '
function myFunction( param1, param2 ){
var x = arguments.param1;
var y = arguments.param2;
return x+y;
}
/**
* @method myFunctionOLD
*/
function myFunctionOLD( param1, param2 ){
var x = arguments.param1;
var y = arguments.param2;
return x+y;
}
function secondFunction( param1, param2 ){
var x = arguments.param1;
var y = arguments.param2;
return x+y;
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);