package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<[^>]*>(*SKIP)(*F)|blue`)
var str = `dont match here <span class="blue" title="This is blue!">Aqua</span>
match ablue here
okay here too <a stuff>match blue here</a>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}