import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)(?<!\\\\)(\"|')(?:[^\\\\]|\\\\.)*?\\1|\\S+";
final String string = "foo \"bar \\\"baz\\\"\" '\\'quux\\''\n\n"
+ "'foo\"bar' \"baz'boz\"\n\n"
+ "hello \"regex\n\n"
+ "world\\\"\"\n\n"
+ "\"escaped escape\\\\\"";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}