re = /(?s)(?<!\\)("|')(?:[^\\]|\\.)*?\1|\S+/
str = 'foo "bar \\"baz\\"" \'\\\'quux\\\'\'
\'foo"bar\' "baz\'boz"
hello "regex
world\\""
"escaped escape\\\\"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end