#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)messenger|zalo"
Local $sString = "chat.zalo.me" & @CRLF & _
"vietnamplus.vn/zalo/zalo" & @CRLF & _
"org.telegram.messenger" & @CRLF & _
"l.messenger.com" & @CRLF & _
"zalo/zalo/zalo"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")