re = /({%)\s*(tag)([^%}]*?)(?:\s*(?:(%})((?:(?:[^{%]*?)|(?R))*)(?:({%)\s*(end\2)\s*(%}))))/m
str = '{% tag xyz %}
{% tag abc %}
{% endtag %}
{
{% endtag %}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end