$re = '/(.*?)\s+(.*?)\s+(.*?:)(.*)/';
$str = '/exe c:\\dos\\main.cpc /l:check';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);