using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!\$transation\[\d+\]='[^']*';$).*$";
string input = @"$transation[123456]='Table9912333';
$transation[123457]='Table8123321';
$transation[123458]='Chair0123334';
$transation[123458]='Chair0123334'sdfds;";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}