// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"UI=MessageBox.\{(.*?)\} \"(.*?)\" \"(.*?)\" \d+ \"(.*?)\" \"(.*?)\" \d+ \"(.*?)\" \"(.*?)\" \d+(?: \"(.*?)\" \"(.*?)\" \d+)?"#).unwrap();
let string = "UI=MessageBox {122f5622-e532-4940-b86f-642eae65a7cc} \"Edit Pandora station 'Bullitnuts Radio'.\" \"What would you like to do to this station?\" 30 \"Delete the station\" \"AckButton 122f5622-e532-4940-b86f-642eae65a7cc \\\"Delete the station\\\"\" 0 \"Edit the station\" \"AckButton 122f5622-e532-4940-b86f-642eae65a7cc \\\"Edit the station\\\"\" 0 \"Cancel\" \"AckButton 122f5622-e532-4940-b86f-642eae65a7cc \\\"Cancel\\\"\" 0";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}