const regex = /[(){}]+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[(){}]+', 'g')
const str = `1,(7287026502032012,18),{(706)},{(101200010)},{(17286)},{(oz)},2.5`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);