using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(JO|jo|Jo|jO)[0-9]{2}(?:[-| ]?[A-Za-z]{4})(?:[-| ]?[0-9]){22}$";
string input = @"jo12aVcd1234567890123456789012
Jo12VVCA1234567890123456789012
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}