const regex = /^(JO|jo|Jo|jO)[0-9]{2}(?:[-| ]?[A-Za-z]{4})(?:[-| ]?[0-9]){22}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(JO|jo|Jo|jO)[0-9]{2}(?:[-| ]?[A-Za-z]{4})(?:[-| ]?[0-9]){22}$', 'gm')
const str = `jo12aVcd1234567890123456789012
Jo12VVCA1234567890123456789012
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}