import re
regex = re.compile(r"(JAN|FEVER)EIRO|MA(RÇ|I)O|ABRIL|JU[NL]HO|AGOSTO|(SETEM|OUTU|NOVEM|DEZEM)BRO", flags=re.MULTILINE)
test_str = ("ABCDEF\n"
"ÇÇÇÇÇ\n"
"JANEIRO\n"
"FEVEREIRO\n"
"MARÇO\n"
"ABRIL\n"
"MAIO\n"
"JUNHO\n"
"JULHO\n"
"AGOSTO\n"
"SETEMBRO\n"
"OUTUBRO\n"
"NOVEMBRO\n"
"DEZEMBRO\n"
"janeiro\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")