using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".[A-Z]{1}";
string input = @"AlbertWeisgerberAllee 35";
RegexOptions options = RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}