use strict;
my $str = 'AlbertWeisgerberAllee 35';
my $regex = qr/(.)([A-Z])/up;
my $subst = '$1-$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";