Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
@
^(?<tag>(?:[a-zA-Z]\w*|_\w+))(?<memspec>(?:(?:(?:\s*\.(?:[a-zA-Z]\w*|_\w+)|(?:\s*\[(?:[^,\]]+)(?:,(?:[^,\]]+))*\]))*)(?:(?:\s*\.\d+|\.\s*(?:\s*\[(?:[^,\]]+)\]))?)))?(?<metadataspec>(?:\s*\.\@(?<metadataid>(?:[a-zA-Z]\w*|_\w+))(?<metadatamemspec>(?:(?:(?:\s*\.(?:[a-zA-Z]\w*|_\w+)|(?:\s*\[(?:[^,\]]+)(?:,(?:[^,\]]+))*\]))*)(?:(?:\s*\.\d+|\.\s*(?:\s*\[(?:[^,\]]+)\]))?)))?))?$
@
gm
Input 1
1
New
tag tag.mem tag.1 tag.[0] tag[0] tag[0].mem tag[0].1 tag[0].[0] tag.mem tag.mem.mem tag.mem.1 tag.mem.[0] tag.mem[0] tag.mem[0].mem tag.mem[0].1 tag.mem[0].[0] tag.@foo.mem[0].[0] tag.mem.@foo.mem[0].[0] tag.1.@foo.mem[0].[0] tag.[0].@foo.mem[0].[0] tag[0].@foo.mem[0].[0] tag[0].mem.@foo.mem[0].[0] tag[0].1.@foo.mem[0].[0] tag[0].[0].@foo.mem[0].[0] tag.mem.@foo.mem[0].[0] tag.mem.mem.@foo.mem[0].[0] tag.mem.1.@foo.mem[0].[0] tag.mem.[0].@foo.mem[0].[0] tag.mem[0].@foo.mem[0].[0] tag.mem[0].mem.@foo.mem[0].[0] tag.mem[0].1.@foo.mem[0].[0] tag.mem[0].[0].@foo.mem[0].[0] tag .mem [ tag.@foo ] .mem .@foo .mem [ 0 ] .a .1