# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^([a-zA-Z]+( [a-zA-Z]+)+) 3$//gm;t' <<< "^[A-C][a-zA-Z0-9]{4}$"