using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"action=""(.*?)""";
string input = @"<html>
<head>
<title>new Start</title>
</head>
<body onLoad=""document.forms[0].submit();"">
<form action=""http://www.google.com"" method=""post"">
<input type=hidden name=""NUMBER"" value=""123456"">
<input type=hidden name=""mode"" value=""display"">
</form>
</body>
</html>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}