package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`action="(.*?)"`)
var str = `<html>
<head>
<title>new Start</title>
</head>
<body onLoad="document.forms[0].submit();">
<form action="http://www.google.com" method="post">
<input type=hidden name="NUMBER" value="123456">
<input type=hidden name="mode" value="display">
</form>
</body>
</html>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}