package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)@\S+|(_)`)
var str = `_
lol_
@username_
lol@username_
lol_@username
lol_@username_`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}