$re = '/@\S+|(_)/m';
$str = '_
lol_
@username_
lol@username_
lol_@username
lol_@username_';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);