using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"400 people drive dark blue cars|400 people drive cars";
string input = @"400 people drive dark blue cars
400 people drive cars";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}